Does the downloaded version of Red Hammer affect OFP's version level?

If you've installed the pay-and-download version of Codemaster's Red Hammer campaign, you don't have to worry about the Red Hammer installation affecting your OFP installation. You can safely install Red Hammer in this way whether you've got OFP version 1.30 (minimum version required), 1.40 or any later version that will come out.

However, care should be taken if you are installing OFP from the OFP Gold CD or upgrading from the OFP Gold Update CD and you've already got OFP version 1.40 or later installed. Read about it here.